Администраторы базы данных

Вопросы и ответы для специалистов по базам данных, которые хотят улучшить свои навыки работы с базами данных и учиться у других в сообществе

3
Настройка оперативной памяти для SQL Server и NUMA
Случайный админ БД тут. Вопрос: Вы бы все еще вручную ограничивали максимальный объем ОЗУ для SQL Server, хотя единственная цель этого сервера - обслуживать только ядро ​​базы данных SQL Server? У меня есть Microsoft Windows 2012 R2 Server, SQL Server 2012 Std, с 32 ГБ ОЗУ. Админ постоянно авторизуется на …

2
Разделение SQL Server 2008 R2 - одна и та же файловая группа, 1 файл, 2 номера_раздела - HELP
Это мой первый опыт работы с разделами в SQL Server. Я узнал об этом из руководства Брента Озара. Несколько раз я сталкивался со странным сценарием; когда я бегу: SELECT * FROM ph.FileGroupDetail ORDER BY partition_number Go Существует одна и та же файловая группа, показывающая два раза с двумя разными номерами …

2
Низкое PLE на узле NUMA 000, высокое на 001
Я смотрю на PLE (продолжительность жизни страницы) через узлы NUMA на наших серверах SQL, и наткнулся на довольно странное распределение. Узел NUMA 000 имеет очень низкое PLE по сравнению с 001. Я не уверен, почему это так. Я проверил на нескольких других серверах SQL в нашей среде, и другие производственные …

6
Зарегистрированные серверы SSMS с намерением приложения ReadOnly
Мы работаем над POC-тестированием SQL Server 2014 с AlwaysOn, и один из пользователей спросил о сохранении конфигурации SSMS с ReadOnly Intent с использованием зарегистрированных серверов в группе локальных серверов. Таким образом, им не нужно вводить псевдоним каждый раз, когда им требуется доступ к реплике ReadOnly . К сожалению, на зарегистрированных …

1
Можно ли сделать резервную копию и восстановить материализованное представление с его данными?
У меня есть некоторые сложные вычисления материализованных представлений, которые я хочу иметь возможность создавать резервные копии и восстанавливать, используя фактические сохраненные данные, а не путем повторного вычисления. Возможно ли это в PostgreSQL 9.4? (альтернатива заключается в создании реальных таблиц, но их сложнее «обновить»)

2
Получить статистику медленно выполняющихся запросов
Моя база данных запускает много разных запросов. Я установил log_min_duration_statementна 1000. Но запросы, зарегистрированные там, не всегда медленные, в большинстве случаев они занимают всего несколько мс. Можно ли получить статистику по всем запросам, и как часто они занимают более 1000 мс?

1
Почему мой запрос к SQL Server ведет себя иначе при обновлении, чем при SELECT?
Я написал запрос SQL Server, который обновляет записи, чтобы иметь последовательный номер после разделения на поле. Когда я запускаю его как оператор SELECT, все выглядит великолепно: DECLARE @RunDetailID INT = 448 DECLARE @JobDetailID INT SELECT @JobDetailID = [JobDetailID] FROM [RunDetails] WHERE [RunDetailID] = @RunDetailID SELECT [OrderedRecords].[NewSeq9], RIGHT([OrderedRecords].[NewSeq9], 4) FROM ( …

9
MongoDB не запускается после изменения каталога данных
Я установил mongodbэкземпляр, используя Yum. , Теперь все работает отлично. Я начал службу с помощью service mongod start. Это работает хорошо. Затем я изменил data directoryи log pathв файле конфигурации. Я перезапустил сервер снова и запустил службу. Но я получаю следующую ошибку: Restarting mongod (via systemctl): Job for mongod.service failed. …

1
Когда SQL Server получает блокировки?
Список уровней изоляции в SQL Server найден здесь говорится , что блокировки записи , полученные в рамках транзакции, сохраняются до конца транзакции. Однако ничего не говорится о том, когда эти замки были приобретены. Блокировки по умолчанию приобретаются в начале транзакции или только тогда, когда они необходимы? Если последнее верно, то …

1
Удалить строку после появления второго конкретного символа слева
У меня есть этот тип значений в столбце таблицы 154646@8@486 45465@6464@654 и т.п. Как я могу удалить все после второго символа @? Мне нужно отобразить 154646@8 45465@6464 Я могу сделать это только для всех @, но не для второго SELECT REPLACE(LEFT('45@Tra@lala', CHARINDEX('@','45@Tra@lala')-1),'_',' ') возвращает 45, но не 45 @ Tra …
10 sql-server 

2
Поля «вне строки» читаются при использовании кластерного индекса?
Я знаю, что при использовании VARCHAR(MAX)/NVARCHAR(MAX)столбцов данные сохраняются out of the row- в строке данных будет указатель на другое место, где хранится «большое значение». У меня есть следующие вопросы: Каждое поле хранится out of the rowили только maxте? Если вы используете clustered indexтаблицу для чтения всей записи, считываются ли поля, …

1
База данных с несколькими файлами .mdf
Я искал в Интернете, но не нашел то, что я ищу. Проблема / запрос состоит в том, что, насколько мне известно, база данных в SQL Server должна иметь один файл .mdf и, возможно, несколько файлов .ndf и один файл .log. Я видел много базы данных с одним mdf и несколькими …

2
Как определить затраты / выгоды от добавления индекса?
По словам Крейга Рингера : Хотя обычно хорошей идеей является создание индекса для (или включая) столбцов внешнего ключа ссылочной стороны, это не обязательно. Каждый добавляемый вами индекс немного замедляет работу DML, поэтому вы платите за производительность за каждый INSERT, UPDATEили DELETE. Если индекс используется редко, он может не иметь смысла. …

1
TSQL Почему Top быстрее с переменной?
Всем утро, Я работал над некоторым умеренно сложным SQL, чтобы «получить» некоторые данные из сторонней базы данных продуктов, чтобы отобразить их в наших собственных приложениях. Я добавил в выборку, чтобы получить верхнюю запись из таблицы в подзапросе (если это имеет смысл) запрос занял около 3 минут, чтобы вернуть окончательный набор …
10 sql-server  t-sql 

1
Как я могу предоставить привилегию подключения к SSIS?
Пытаясь запустить пакеты служб SSIS с помощью dtexec.exe, я получил это сообщение об ошибке: Could not load package "D:\Filename.dtsx" because of error 0xC00160AE. Description: Connecting to the Integration Services service on the computer "" failed with the following error: "Access is denied." By default, only administrators have access to the …

Используя наш сайт, вы подтверждаете, что прочитали и поняли нашу Политику в отношении файлов cookie и Политику конфиденциальности.
Licensed under cc by-sa 3.0 with attribution required.