Nginx зависает, используя «service nginx start»


12

Я скомпилировал nginx с пользовательскими путями для моего производственного сервера, и когда я пытаюсь запустить / перезапустить службу, используя:

service nginx start

или

service nginx restart

Он входит в новую строку без возврата оболочки: Изображение терминала при запуске команды

Так что проблема в том, что я не могу контролировать nginx с помощью serviceкоманды. Сервис на самом деле работает, но он не возвращает мне оболочку, поэтому мне всегда нужно нажимать ctrl+, cчтобы вернуть его.

Я также должен упомянуть, что nginx прекрасно работает при вызове его собственной nginxкомандой и легко останавливается или перезагружается nginx -s stop/reload.

Эта проблема сохраняется и при использовании systemctl start nginx, но systemctl stop nginxработает просто отлично.

Информация:

$ lsb_release -a
    Distributor ID: Ubuntu
    Description:    Ubuntu 15.10
    Release:    15.10
    Codename:   wily

$ uname -r
    4.2.0-27-generic

$ nginx -V
    nginx version: nginx/1.9.11
    built by gcc 5.2.1 20151010 (Ubuntu 5.2.1-22ubuntu2) 
    built with OpenSSL 1.0.2d 9 Jul 2015
    TLS SNI support enabled
    configure arguments: --sbin-path=/usr/bin/nginx --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --http-log-path=/var/log/nginx/access.log --with-debug --with-pcre --with-http_ssl_module

$ cat /etc/default/nginx
    NGINX_CONF_FILE=/etc/nginx/nginx.conf
    DAEMON=/usr/bin/nginx

$ cat /etc/init.d/nginx
    NGINX_BIN=/usr/bin/nginx
    test -x $NGINX_BIN || { echo "$NGINX_BIN not installed"; 
        if [ "$1" = "stop" ]; then exit 0;
        else exit 5; fi; }
    NGINX_PID=/var/run/nginx.pid

    # Check for existence of needed config file and read it
    #NGINX_CONFIG=/etc/sysconfig/nginx
    #test -r $NGINX_CONFIG || { echo "$NGINX_CONFIG not existing";
    #   if [ "$1" = "stop" ]; then exit 0;
    #   else exit 6; fi; }
    #
    # Read config   
    #. $NGINX_CONFIG

    # Source LSB init functions
    # providing start_daemon, killproc, pidofproc, 
    # log_success_msg, log_failure_msg and log_warning_msg.
    # This is currently not used by UnitedLinux based distributions and
    # not needed for init scripts for UnitedLinux only. If it is used,
    # the functions from rc.status should not be sourced or used.
    #. /lib/lsb/init-functions

    # Shell functions sourced from /etc/rc.status:
    #      rc_check         check and set local and overall rc status
    #      rc_status        check and set local and overall rc status
    #      rc_status -v     be verbose in local rc status and clear it afterwards
    #      rc_status -v -r  ditto and clear both the local and overall rc status
    #      rc_status -s     display "skipped" and exit with status 3
    #      rc_status -u     display "unused" and exit with status 3
    #      rc_failed        set local and overall rc status to failed
    #      rc_failed <num>  set local and overall rc status to <num>
    #      rc_reset         clear both the local and overall rc status
    #      rc_exit          exit appropriate to overall rc status
    #      rc_active        checks whether a service is activated by symlinks
    . /etc/rc.status

    # Reset status of this service
    rc_reset

    # Return values acc. to LSB for all commands but status:
    # 0   - success
    # 1       - generic or unspecified error
    # 2       - invalid or excess argument(s)
    # 3       - unimplemented feature (e.g. "reload")
    # 4       - user had insufficient privileges
    # 5       - program is not installed
    # 6       - program is not configured
    # 7       - program is not running
    # 8--199  - reserved (8--99 LSB, 100--149 distrib, 150--199 appl)
    # 
    # Note that starting an already running service, stopping
    # or restarting a not-running service as well as the restart
    # with force-reload (in case signaling is not supported) are
    # considered a success.

    case "$1" in
        start)
        echo -n "Starting nginx "
        ## Start daemon with startproc(8). If this fails
        ## the return value is set appropriately by startproc.
        /sbin/startproc -p $NGINX_PID $NGINX_BIN

        # Remember status and be verbose
        rc_status -v
        ;;
        stop)
        echo -n "Shutting down nginx "
        ## Stop daemon with killproc(8) and if this fails
        ## killproc sets the return value according to LSB.

        /sbin/killproc -p $NGINX_PID -TERM $NGINX_BIN

        # Remember status and be verbose
        rc_status -v
        ;;
        try-restart|condrestart)
        ## Do a restart only if the service was active before.
        ## Note: try-restart is now part of LSB (as of 1.9).
        ## RH has a similar command named condrestart.
        if test "$1" = "condrestart"; then
            echo "${attn} Use try-restart ${done}(LSB)${attn} rather than condrestart ${warn}(RH)${norm}"
        fi
        $0 status
        if test $? = 0; then
            $0 restart
        else
            rc_reset    # Not running is not a failure.
        fi
        # Remember status and be quiet
        rc_status
        ;;
        restart)
        ## Stop the service and regardless of whether it was
        ## running or not, start it again.
        $0 stop
        $0 start

        # Remember status and be quiet
        rc_status
        ;;
        force-reload)
        ## Signal the daemon to reload its config. Most daemons
        ## do this on signal 1 (SIGHUP).
        ## If it does not support it, restart the service if it
        ## is running.

        echo -n "Reload service nginx "
        ## if it supports it:
        /sbin/killproc -p $NGINX_PID -HUP $NGINX_BIN
        #touch /run/nginx.pid
        rc_status -v

        ## Otherwise:
        #$0 try-restart
        #rc_status
        ;;
        reload)
        ## Like force-reload, but if daemon does not support
        ## signaling, do nothing (!)

        # If it supports signaling:
        echo -n "Reload service nginx "
        /sbin/killproc -p $NGINX_PID -HUP $NGINX_BIN
        #touch /run/nginx.pid
        rc_status -v

        ## Otherwise if it does not support reload:
        #rc_failed 3
        #rc_status -v
        ;;
        reopen)
            echo -n "Reopen the logfiles "
            /sbin/killproc -p $NGINX_PID -USR1 $NGINX_BIN
            rc_status -v
            ;;

        status)
        echo -n "Checking for service nginx "
        ## Check status with checkproc(8), if process is running
        ## checkproc will return with exit status 0.

        # Return value is slightly different for the status command:
        # 0 - service up and running
        # 1 - service dead, but /run/  pid  file exists
        # 2 - service dead, but /var/lock/ lock file exists
        # 3 - service not running (unused)
        # 4 - service status unknown :-(
        # 5--199 reserved (5--99 LSB, 100--149 distro, 150--199 appl.)

        # NOTE: checkproc returns LSB compliant status values.
        /sbin/checkproc -p $NGINX_PID $NGINX_BIN
        # NOTE: rc_status knows that we called this init script with
        # "status" option and adapts its messages accordingly.
        rc_status -v
        ;;
        probe)
        ## Optional: Probe for the necessity of a reload, print out the
        ## argument to this init script which is required for a reload.
        ## Note: probe is not (yet) part of LSB (as of 1.9)

        test /etc/nginx/nginx.conf -nt /run/nginx.pid && echo reload
        ;;
        *)
        echo "Usage: $0 {start|stop|status|try-restart|restart|force-reload|reload|probe}"
        exit 1
        ;;
    esac
    rc_exit

ОБНОВЛЕНИЕ : проблема также сохраняется при использовании контейнера Docker на CoreOS alpha.

ОБНОВЛЕНИЕ 2 : Вот выходы для strace -o log -f service nginx startи journalctl -xe:

strace -o log -f service nginx start Вывод журнала [слишком долго для публикации здесь]


    journalctl -xe
    Feb 26 07:25:38 lucifer polkitd(authority=local)[870]: Registered Authentication Agent for unix-process:8181:8813595 (system bus name :1.77 [/usr/bin/pkttyagent --notify-fd 5 --fallback], o
Feb 26 07:25:38 lucifer systemd[1]: Starting The NGINX HTTP and reverse proxy server...
-- Subject: Unit nginx.service has begun start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit nginx.service has begun starting up.
Feb 26 07:25:38 lucifer nginx[8211]: nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
Feb 26 07:25:38 lucifer nginx[8211]: nginx: configuration file /etc/nginx/nginx.conf test is successful
Feb 26 07:25:38 lucifer systemd[1]: nginx.service: PID file /var/run/nginx.pid not readable (yet?) after start: No such file or directory
Feb 26 07:25:43 lucifer polkitd(authority=local)[870]: Unregistered Authentication Agent for unix-process:8181:8813595 (system bus name :1.77, object path /org/freedesktop/PolicyKit1/Authen

1
Так nginxкак работает нормально при запуске из cli самостоятельно, вам необходимо отладить его служебный скрипт.
— Друки

Попробуйте решить проблему. Он покажет вам, что системный вызов не может завершить. Просто установите strace, затем strace -ff service nginx start.
— беспокойство

@drookie @anx Я опубликовал результаты journalctlи straceздесь, но, честно говоря, я понятия не имею, как понять проблему по результатам Strace. Я был бы признателен за небольшую помощь, если это возможно.
— T0M XeOn LuCiFeR

@ T0M XeOn LuCiFeR вы исправили эту проблему?
— Бхаргав Патель

Может быть, связано с этой ошибкой: bugs.launchpad.net/ubuntu/+source/nginx/+bug/1581864
— Эллиот Б,

Ответы:


9

У меня та же проблема с Ubuntu 16.04, systemd и NginX 1.10.1 из исходного кода.

Я использовал файл nginx.service по умолчанию: https://www.nginx.com/resources/wiki/start/topics/examples/systemd/

Проблема была в nginx.pid lcoation, чтобы исправить это я:

Загорелся Nginx без сервиса

sudo nginx start

Обновлено местонахождение базы данных:

sudo updatedb

Нашел расположение pid файла

locate "nginx.pid"

И обновил файл nginx.service до того места, где я его нашел

PIDFile=/usr/local/nginx/logs/nginx.pid

(Понятия не имею, почему он хранится в моих журналах dir ...)

Затем запустите daemon-reload, чтобы перезагрузить файл nginx.service.

systemctl daemon-reload

После этого "systemctl start nginx" работает как шарм. Надеюсь это поможет.


Приведенный в /usr/local/nginx/logs/nginx.pidкачестве пути для PIDFileменя работал (с использованием сервера Ubuntu 16.04.2 и nginx 1.12.1). Thx
— youssman

Это сработало для меня. При сборке nginx из исходного кода я настроил его с помощью «--pid-path = / usr / local / nginx / nginx.pid». Когда я настраивал nginx.service, я использовал неправильный путь и вызывал ту же проблему. При исправлении это не привело к зависанию и последующему прекращению. Благодарность!
— Гит

3

Он зависает из-за этой ошибки:

PID file /var/run/nginx.pid not readable (yet?) after start

Более новые дистрибутивы Linux поставляются с systemd . Если вы используете сервис, связанный с вашим дистрибутивом, вы уже настроите его для systemd.

Поскольку вы компилируете nginx из исходных кодов и используете файл инициализации SysV ( /etc/init.d/nginx ), systemd будет использовать генератор для его анализа ( systemd-sysv-generator ).

В вашем скрипте SysV вы определяете файл pid и запускаете процесс с:

NGINX_PID=/var/run/nginx.pid
...
/sbin/startproc -p $NGINX_PID $NGINX_BIN

Если я не ошибаюсь, вы используете сценарий инициализации SUSE Linux в Ubuntu (из-за команды startproc ), эта команда startproc только читает файл pid (указанный в параметре -p ), но не создает его, поэтому systemd не могу найти файл pid, и он зависает.

В вашем случае решением будет либо создать pid-файл в вашем скрипте инициализации SysV (в каталоге /var/run/nginx.pid ), либо использовать скрипт инициализации Ubuntu SysV, либо системный.

Это также может произойти (не то, что происходит с вами), когда у вас есть правильный сценарий инициализации SysV, который создает файл pid, но он отличается от того, который был прокомментирован в верхней части файла. Генератор systemd читает комментарии, например этот:

# pidfile: /var/run/nginxd.pid

И использует определенный там pid-файл.

Дополнительная информация:


2

Похоже, /usr/lib/systemd/system/nginx.serviceэто неправильно сформировано. Убедитесь, что эта строка установлена:

PIDFile=/var/run/nginx.pid

В качестве альтернативы вы можете скопировать [Service]раздел в новый файл с именем /etc/systemd/system/nginx.service. Размещенные в нем файлы модулей /etc/systemd/systemпозволяют переопределять разделы, не дублируя весь файл, установленный менеджером пакетов.

Используя наш сайт, вы подтверждаете, что прочитали и поняли нашу Политику в отношении файлов cookie и Политику конфиденциальности.
Licensed under cc by-sa 3.0 with attribution required.