Ошибка mount.cifs (2): нет такого файла или каталога при использовании префикса


11

Я попробовал эту команду:

mount -t cifs //server/share/directory /mnt/directory -o credentials=/path/to/cifs.credentials --verbose

Ответ:

mount.cifs kernel mount options: ip=<IP of server>,unc=\\server \share,user=<username>,prefixpath=directory,pass=********
mount error(2): No such file or directory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Тем не менее, если я попробую ту же команду без префикса пути:

mount -t cifs //server/share /mnt/directory -o credentials=/path/to/cifs.credentials --verbose

Это работает, и я могу получить доступ к / mnt / directory / directory.

Я получаю ту же ошибку, если явно указать префиксный путь в опциях, то есть:

mount -t cifs //server/share /mnt/directory -o credentials=/path/to/cifs.credentials,prefixpath=directory --verbose

Дополнительная информация:

  • Я могу подключиться к нужному пути, используя smbclient //server/share -U username -W domain -D directory
  • версия mount.cifs: 5.5
  • Ядро Debian 3.2.0-4-amd64
  • Я могу подключиться на другой машине, используя mount.cifs версии 4.5 в ядре Debian 2.6.32-5-amd64

Есть идеи, почему префиксный путь, кажется, вызывает проблемы? Этот же путь работал недавно; Я подозреваю, что за новым поведением стоит обновление пакета на стороне Linux или обновление Windows.


Это для NAS? Когда вы говорите, что пытаетесь «без пути префикса», команда выглядит так же. Это опечатка?
— Осьминог

Это для NetApp SAN. Вы правы, это была опечатка - я исправил это.
— черд

Служба поддержки NetApp должна была обеспечить трассировку пакетов, где они обнаружили, что mount.cifs отправляет каталог // server / share //, а не // server / share / directory. Это кажется причиной проблемы (хотя и не является решением).
— черд

Ответы:


6

Наконец-то нашли решение этой проблемы, которое работает с нашим NetApp. Если вам не нужен DFS, попробуйте монтировать с nodfsопцией.

mount -t cifs //server/share/directory /mnt/directory -ocredentials=/path/to/cifs.credentials,nodfs

Мы также используем netapp. Спасибо за этот обходной путь, он спас мой день.
— Danduk82
Используя наш сайт, вы подтверждаете, что прочитали и поняли нашу Политику в отношении файлов cookie и Политику конфиденциальности.
Licensed under cc by-sa 3.0 with attribution required.