Системная ошибка 58 при доступе к общим ресурсам в Windows 7 из XP


16

Я получаю следующее сообщение об ошибке при доступе к общим ресурсам Windows 7 из XP.

Системная ошибка 58 произошла. Указанный сервер не может выполнить запрошенную операцию.

Обе машины находятся в одном домене. Машина с Windows XP может просматривать и получать доступ ко всем другим общим ресурсам, кроме Windows 7. Ни на одной из машин нет брандмауэра.


Вы проверили общие ресурсы Windows 7 и подтвердили, что они разрешают доступ к вашему имени пользователя или группе пользователей?
— Гном

да. одни и те же пользователи зарегистрированы на обеих машинах. даже не чистый вид работает.
— nysingh

1
Перезапуска службы сервера в Windows 7 было достаточно, чтобы исправить мою проблему.

1
Остановка и перезапуск службы сервера на компьютере с Win 7 x64 позволил машине XP подключиться к общему ресурсу, расположенному на компьютере с Windows 7 x64. Это было определенно менее травматично, чем любое другое исправление. Эта проблема, кажется, приходит и уходит, подтверждая тезис о том, что есть какая-то ошибка, которая может быть временно устранена, но всегда возвращается.

Ответы:


20

Изменение настроек NTLM в локальной политике у меня не сработало.

То, что сделало работу, упомянуто здесь: текст ссылки

... вам нужно сообщить Windows, что вы хотите использовать компьютер в качестве файлового сервера и что он должен распределять ресурсы соответствующим образом. Установите следующий раздел реестра в «1»:

HKLM \ SYSTEM \ CurrentControlSet \ Control \ Диспетчер сеансов \ Управление памятью \ LargeSystemCache

и установите следующий раздел реестра на «3»:

HKLM \ SYSTEM \ CurrentControlSet \ Services \ LanmanServer \ Параметры \ Размер

После изменения двух параметров реестра я просто перезапустил службу «Сервер» в Windows 7, и теперь общий доступ работает нормально.


Отлично, это исправило мою проблему для меня! Благодарность!
— Майкл Галос

Brilliant! Работал на меня. PS Ссылка " alan.lamielle.net/2009/09/03/… " истекла .
— user53621

10

хорошо, ребята, вот ответ.

проблема заключалась в том, что ответ NTML не был настроен с обеих сторон. Мне нужно было настроить следующее на xp и wind7, и перезагрузка сделала свое дело.

  1. gpedit.msc
  2. Настройки Windows. Разверните «Локальные политики» и выберите «Параметры безопасности»
  3. Alternate: введите secpol.msc, чтобы запустить редактор
  4. Найдите «Сетевая безопасность: Уровень проверки подлинности LAN Manager» в списке и дважды щелкните по нему.
  5. Измените настройку с «Отправлять только NTMLv2-ответ» на «Отправлять LM и NTLM - используйте сеанс NTLMv2, если согласовано»

9

Также может быть полезно узнать точную причину, прежде чем выбрать одно из этих решений. У меня недавно была такая же проблема при попытке синхронизировать файлы с Windows 2003 Server на рабочую станцию ​​Windows 7. Случайно сервер потерял бы свое соединение с коробкой Win7, и попытка команды NET USE для сопоставления диска возвратила бы Состояние 58 как это.

Перезагрузка окна Win7 исправит это, но это казалось радикальным. Посмотрев глубже с Wireshark, мы обнаружили, что запрос SMB направляется в коробку Win7, а ответ SMB «Out Of Memory» возвращается. Остановка и перезапуск службы сервера на коробке Win7 решил проблему, по крайней мере временно, и намного лучше и быстрее, чем перезагрузка. Я ожидаю, что изменения в реестре для большого системного кэша разрешат его полностью, но эти изменения могут не подходить для постоянного изменения, просто чтобы устранить временную проблему.


1
  1. Убедитесь, что брандмауэры Windows действительно отключены, отключите все антивирусы, а также отключите простой обмен файлами. Иногда это помогает с ошибкой 58.

  2. Попробуйте установить обнаружение топологии канального уровня на компьютере с XP.

  3. Проблема может заключаться в разрешениях учетной записи, в которых Win7 довольно строгая. Проверьте разрешения на общий ресурс.

  4. И последнее: все ли машины полностью исправлены?


1. все брандмауэры выключены. 2. Попробуем топологию канального уровня. 3. Нет разрешений. даже администраторы домена получают одинаковые результаты (ошибка 58) 4. все машины полностью исправлены.
— nysingh

обнаружение топологии канального уровня установлено. неудачно.
— nysingh

Вы пытались отключить простой обмен файлами? Успешно ли выполняется ping (1) с именем машины (2) с IP-адресом? Что происходит при попытке доступа к общим ресурсам по IP-адресу Win7?
— Harrymc

1

Системная ошибка 58 означает, что произошел сбой аутентификации - по крайней мере, я получаю эту ошибку, если набрал неправильный пароль.

Я тоже столкнулся с той же проблемой. Мне дали имя общего сетевого ресурса, имя пользователя и пароль для доступа к нему. Я попробовал, но не получилось. Компьютер находится в нашей сети, поэтому он также должен быть в нашем домене ...

Проблема заключалась в том, что я был в домене X, поэтому он автоматически пытался войти в систему с помощью X\username. Конечно, такого имени пользователя не существует, потому что фактический пользователь, которого мне нужно было использовать Y\username, потому что отдел, который создал пользователя, был в домене Y, поэтому они этого не заметили и работали на них.

Извлеченные уроки: всегда сообщайте, в каком домене находится пользователь, если вам предоставлены учетные данные домена.

(надеюсь, что это поможет кому-то, кто запутается в этом.)


0

Недавно я столкнулся с той же проблемой при попытке доступа к общей папке Windows 7 из Windows XP SP2. Я мог получить доступ к другим ресурсам на Windows Vista и XP, но не Windows 7, хотя я мог видеть его, я не мог получить к нему доступ. После долгих поисков неисправностей я обнаружил, что система Windows 7 принадлежала домашней группе. После того как я удалил (или покинул) систему Windows 7 из домашней группы, я смог получить доступ к общему ресурсу с надлежащими учетными данными. Надеюсь, что это поможет всем, кто может столкнуться с подобной проблемой.


0

Для меня это было то, что SMB был отключен. Я выполнил эти команды в командной строке с повышенными правами:

sc.exe config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/nsi
sc.exe config mrxsmb10 start= auto
Используя наш сайт, вы подтверждаете, что прочитали и поняли нашу Политику в отношении файлов cookie и Политику конфиденциальности.
Licensed under cc by-sa 3.0 with attribution required.