установить запись Google Apps SPF в Amazon AWS Route 53


13

Я использую новый графический интерфейс AWS для Route 53 для настройки записей моего домена. Однако консоль AWS не примет рекомендованную запись SPF Служб Google v=spf1 include:_spf.google.com ~all(см. Здесь ).

Это продолжает давать мне сообщение об ошибке

The record set could not be saved because:
- The Value field contains invalid characters or is in an invalid format.

Это происходит при сохранении как SPF и TXT. Есть идеи?


Вы должны процитировать это, что меня тоже отбросило. Инструкции Google ужасны , поэтому я написал полное руководство по этому вопросу
— Энди Рэй,

Ответы:


31

Я должен был обернуть свою запись SPF в кавычки, чтобы она работала.

"v=spf1 include:_spf.google.com ~all"


1

Это новая функция для консоли. Скорее всего, консольная часть отклоняет «недопустимые» символы, а не систему, лежащую в основе.

Я бы попробовал установить его с помощью одного из множества инструментов, доступных для настройки Route 53, и если это не сработает, свяжитесь с Amazon


1

Мое исправление заключалось в том, чтобы заключить запись в кавычки и заменить ~ на -.

Вот значение, которое работает:

"v = spf1 include: _spf.google.com -all"


2
Согласно support.google.com/a/answer/178723?hl=ru вы должны использовать ~ все не все для Служб Google.
— Шон Баннистер

1
Единственная причина, по которой я заменил ~ на - это заставить 53 принять его, но, к моему удивлению, Google Apps также признал его действительным.
— Жак Сниман

-1

Используя удвоения, вы можете установить это значение без появления сообщений об ошибках. Это работало нормально для меня.


Чтобы уточнить, он хотел сказать «двойные кавычки», что обходит проверки на недопустимые символы.
— Джастин Голдберг
Используя наш сайт, вы подтверждаете, что прочитали и поняли нашу Политику в отношении файлов cookie и Политику конфиденциальности.
Licensed under cc by-sa 3.0 with attribution required.