Где я могу использовать префикс документации IPv6


13

В настоящее время мы создаем сетевой курс с практической частью, где студенты должны настроить небольшую сеть в виртуальной среде.

Однако мы не уверены, какие префиксы ipv6 мы можем использовать для конфигурации. Префикс документации IPv6 ( 2001:db8::/32 RFC3849 ), кажется, подходит. Однако кто-то сказал, что этот префикс должен использоваться только в текстовых примерах и никогда не должен конфигурироваться нигде, даже в изолированной тестовой сети. (Конечно, это будет работать, но может рассматриваться как нарушение RFC).

Проблема здесь в том, что RFC довольно абстрактен по этому поводу, и все зависит от того, как интерпретировать термин «документация». Я не смог найти никаких источников об использовании в экспериментальных тестовых / обучающих сетях или спецификации "документации" в Интернете.

Можете ли вы помочь мне?

Ответы:


11

Если ваша тестовая среда отделена от локальной сети, вы гипотетически можете использовать любые адреса IPv6, которые не зарезервированы для специальных целей. Однако, если вы ищете эквивалент частных IPv4-адресов, вам следует взглянуть на RFC4193 .

Там вы можете увидеть, что fc00::/7это подходящая подсеть для тестирования.

С другой стороны, вы могли получить префикс IPv6 от вашего интернет-провайдера, который вы можете использовать для своих нужд.


Да, мы также рассматривали fc00: / 7 (или, точнее, fd: 00/8) в качестве опции. Однако это означает, что нам нужно использовать 40 случайно созданных битов + подсеть, чтобы получить префикс / 64 (согласно RFC). Использование, например, 0000 ... в качестве «случайного» числа нарушило бы RFC, использование реальных случайных чисел сделало бы адреса IPv6, вероятно, очень трудными для запоминания для студентов, что также нежелательно.
— Sliebald

ULA не эквивалентно частной адресации RFC 1918. При частной адресации IPv4 предполагается, что несколько сетей будут использовать одну и ту же адресацию, но ULA предназначена для предотвращения этого, чтобы шансы двух сетей, использующих одну и ту же адресацию, были очень и очень малы.
— Рон Мопин

Я бы также посоветовал использовать один или несколько префиксов в соответствии с RFC4193 из fd :: / 8. В реальной жизни ученики также не столкнутся с 48-летием, которое будет легко запомнить.
— Марк 'Netztier' Luethi

Это правда, однако есть много префиксов fX ... / 64, которые являются особыми для IPv6, поэтому они также не помогают решить эту проблему.
— Слибальд

Шансы каждой конкретной пары сетей, использующих одинаковые адреса, очень малы, но вероятность того, что они являются двумя сетями в мире с одинаковым префиксом ULA, на самом деле очень высоки.
— Питер Грин

19

Префикс документации IPv6 (2001:db8:::/32)должен использоваться ТОЛЬКО для целей документирования. Это означает письменные примеры, схемы, презентации PPT, пояснения к учебникам и т. Д.

Этот диапазон не должен использоваться в практических сетях.

Существует «частный диапазон IP-адресов», fc00::/7который должен использоваться для тестирования устройств, демонстраций, курсов и т. Д. Согласно RFC4193.

Одноадресные адреса в этом диапазоне должны использоваться в локальных сетях без доступа к общедоступному Интернету.


Что касается fc00: / 7, см. Мой комментарий к Саше Р. Некоторые из нас внутренне также утверждали, что сеть, которую мы используем, также может рассматриваться как документация (или, по крайней мере, она используется в качестве практической части документации / объяснения IPv6 для студенты). Просто из RFC я не вижу ничего, определяющего, что документация является строго письменным текстом. Есть ли у вас источник для этой интерпретации?
— sliebald

@StefanLiebald В APNIC они заявляют, чтоThe documentation prefix is the IPv6 address range that has been set aside for this purpose.
— jcbermu

@ jcbermu Эй, они также заявляют: «В технических книгах, статьях и учебных материалах часто необходимо показывать примеры используемых IP-адресов». С моей точки зрения, «учебный материал» идеально соответствовал бы тому, что мы планируем делать. Тренировка для меня включает в себя практические упражнения (или даже синонимы).
— Слибальд

8

Просто из RFC я не вижу ничего, определяющего, что документация является строго письменным текстом. Есть ли у вас источник для этой интерпретации?

В соответствии со специальным регистром адресов IANA IPv6 , 2001:db8::/32диапазон адресов документации не может использоваться при адресации источника или назначения, не является ни пересылаемым (маршрутизируемым), ни глобально достижимым и не резервируется никаким протоколом. Это делает диапазон адресов неподходящим для использования в реальной сети.

Как, например, вы могли бы использовать какие-либо адреса в этом диапазоне, если их нельзя использовать в качестве адресов источника или назначения в IP-пакетах?

На самом деле, вы можете работать с некоторыми устройствами, которые просто отказываются использовать этот диапазон адресов, и это вполне соответствует стандартам. В конце концов, IANA владеет всей адресацией IPv4 и IPv6.


Замечание: на самом деле, IANA не владеет унаследованными сетями IPv4, выделенными Центральным реестром Интернета до существования ANA.
— JFL

4
@JFL, IANA, именно так мы и получили 172.16.0.0/12диапазон личных адресов. IANA обратилась в юридическую фирму, которая «владела» диапазоном адресов для частной адресации. Юридическая фирма отказалась, поэтому IANA просто взяла это. В результате судебного разбирательства было установлено, что IANA фактически владеет всей IP-адресацией
— Рон Мопин
Используя наш сайт, вы подтверждаете, что прочитали и поняли нашу Политику в отношении файлов cookie и Политику конфиденциальности.
Licensed under cc by-sa 3.0 with attribution required.